Not sure of the right way to handle this. There are two meanings here,
- one of them is
sql-serverspecific and it's the
quoted_identiferoption, see also "What does
- the other is universal, and it's the function used to safely quote an identifier, see also "How do you quote an identifier in SQL Server"
I'm thinking we should have two options
sql-server-quoted-identifierfor the parse option (input) in SQL-server, without which an error will be generated.
quote_identifierfor the universal option to safely output a quoted identifier.
I went ahead and created
sql-server-quoted-identifier being we have 7 questions specific to
sql-server-quoted-identifier (two of them are myself). I'm open to the tag being renamed or whatever if a better more appropriate name is found but these two concepts seem discrete from my perspective.
The previous tag
quoted_identifier should probably be renamed to etiher,
quote_identifier(to describe what people are likely to search for)
delimited_identifier(to describe what the spec calls the result of the function). The spec calls it a
delimited_identifierbut explicitly states in the grammar that the only delimiter is a the double quote. Note: Microsoft SQL's
QUOTENAME(which provides this functionality) breaks the spec and produces an identifier quoted with
My big question moving forward is if we should put the RDBMS specific options into the system without the tie-into the RDBMS, or try to enforce a convention that place them under the RDBMS name? (