1

I'm able to post any question but sometimes unable to add comments to the answers posted and below error message is displayed on the top of the screen.

Database Administrators Stack Exchange requires external JavaScript from another domain, which is blocked or failed to load.

I'm using IE 11.0 and Chrome 61.0

So, please guide what settings needs to be done to fix this?

  • 1
    I don't have this issue. Are you on a corporate network? What AV and malware, etc, software are you using? – jcolebrand Oct 23 '17 at 23:45
  • 1
    I work for US state department and have McAfee software. Other than this, I don't have access to any of the requested information. – Sri Oct 24 '17 at 13:37
3

Debugging

If you open up the Developer Console (F12) in Chrome and switch to the sources tab, you will find that some portions of the sites you are visiting are being serviced from different domains on the internet.

Sample dba.meta.stackexchange.com

Here is a sample output of what the dba.meta.stackexchange.com site looks like source-wise:

Picture of web sources for elements in https://dba.meta.stackexchange.com

Sample serverfault.com

Here is a sample output of the sources for https://serverfault.com:

Pictue of web sources for elements in https://serverfault.com

Summary

As you can see, the various stackexchange sites require components from different sources on the internet depending on who was responsible for the extensions used on that specific stackexchange site. This is possibly why you are observing different behaviour on different sites.

Solution

Ask the network security administrator at the U.S. state department to unblock the required sites on the firewall for you to post comments on the various stackexchange.com sites.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .