3

I have been trying to post a question in the Database Administrators Site for a while and each time I get the error:

An error occurred submitting the question

I am using IE10. Are there any known issues with it and this site? Or some limitation on the questions? I see the same behavior on Stack Overflow.

PS: I can post the content of my question here if it is needed.

UPDATE

It almost gave up but I finally managed to post the question, it seems there is some issue with drop statements.

This is my question.

I had 2 drop statements in the code that I posted, for some reason each time I added them I would get the error. I had to replace them with :

--Here my drop for my_test_table1 and my_test_table2

Funny enough I can not add the drop statements here either and it doesn't work either when I add "--" at the beginning.

Could this be an issue related with sql injection? This is the error:

enter image description here

This is the drop statement I am trying to add: enter image description here

  • Can you try posting a different, simpler question with none of the same code or keywords? Would help narrowing down whether this is a you/permissions/browser issue, or a content issue. – Aaron Bertrand May 23 '14 at 14:56
  • @AaronBertrand it seems to me that it is a content issue, I can not post the code in this question either or even in this comment. – Dzyann May 23 '14 at 15:08
  • Can you post it as a comment - exactly as you tried to submit it, and on its own? Is it possible you have any add-ins or userscripts that are interfering with content submission? – Aaron Bertrand May 23 '14 at 15:09
  • @ I tried adding the same line in one of my Stack Overflow questions and I get the same error. It is just a drop of the table my_test_table1. I also tried to add it in the comments here and in the question here. I tried using -- at the beginning. – Dzyann May 23 '14 at 15:10
  • Yes but please post exactly what it is, instead of describing it. You know, so others might be able to try to reproduce exactly the problem you are having. – Aaron Bertrand May 23 '14 at 15:10
  • @AaronBertrand the problem is that it doesn't let me post it :P so that is why I keep describing it. – Dzyann May 23 '14 at 15:12
  • Then take a screen shot and add it to your question, please. – Aaron Bertrand May 23 '14 at 15:12
  • Or add the code in a pastebin site and post the link here. – ypercubeᵀᴹ May 23 '14 at 15:15
  • @AaronBertrand I just added it. – Dzyann May 23 '14 at 15:16
  • @ypercube sorry I can't access pastebin from work. They have that page blocked. – Dzyann May 23 '14 at 15:16
  • There are many other paste sites. Are all blocked? – ypercubeᵀᴹ May 23 '14 at 15:17
  • I suspect it's something on your end. Since it is affecting both Stack Overflow and dba.stackexchange, perhaps you should try to see if it also affects you on other sites outside of this network. Try posting a question with that code in it on msdn forums, or sqlservercentral, or yahoo answers, etc. Also try disabling all add-ins, plugins, userscripts etc. And try posting the same from your home network when you leave work today - for all we know it's something your work proxy is doing. – Aaron Bertrand May 23 '14 at 15:18
  • @Dzyann Could it be some non-visible character from your editor? Did you copy paste the code (from which editor?) or typed it? – ypercubeᵀᴹ May 23 '14 at 15:20
  • @ypercube I typed it, also copy, it doesn't work either way. It seems Aaron is correct. – Dzyann May 23 '14 at 15:25
  • @AaronBertrand you are correct, I tried using MSDN and it happens the same. I disabled the Add-ons and it is not the cause. I just tried using HTTPS as MicSim suggested and it worked. – Dzyann May 23 '14 at 15:56
5

There are firewalls that are able to filter the network traffic for SQL keywords and statements (at least Cisco has such features).

A work-around would be to connect to StackOverflow / StackExchange sites using HTTPS. Then you should be able to post. This is due to HTTPS traffic being encrypted so your SQL statements won't be in human (in this case computer) readable format. The firewall then cannot sniff your posts any longer.

For example just call https://stackoverflow.com/ instead of https://stackoverflow.com/.

  • In my case it seems it is the Forefront TMG that also has SQL injection filtering for security is causing the issue. – Dzyann May 23 '14 at 17:35
5

I have this exact problem myself. For me it is the text "group by" I cannot submit it from work. It is a firewall thing. The firewall does not like it.

I have found myself writing Stack Exchange Data Explorer queries that look like:

select ...
from ...
group --fix
by some column
  • 3
    Indeed, searching the internet revealed that at least Cisco firewalls are able to filter SQL queries. A work-around would be to connect to StackOverflow / StackExchange using HTTPS. Then you should be able to post. – MicSim May 23 '14 at 15:44
  • 1
    @MicSim I just tried using HTTPS as you suggested and it worked thanks! – Dzyann May 23 '14 at 15:56
  • @MacSim you might like to post that as an answer here, and here and here too! – Jack Douglas May 23 '14 at 16:13
4

I don't know of any specific issues with IE10 but there are various limits on questions, including minimum and maximum length.

I suggest you try posting the first line of the question and editing in the rest.

---edit:

This may be related to Rejection of text containing SQL statements

The problem isn't with SO, you have some kind of filtering software on your network that is sniffing out SQL Injection attempts and it is getting caught and rejected at the network level. If you want to confirm this, you can try typing the same words into Google, Bing or Yahoo and I bet you will get the same error.

In our case it was the Intrusion Protection Module of our Cisco firewall that had a blacklist with several SQL commands that are especially dangerous.

  • I did that, but I had to do nearly 50 edits, in the middle other people thought I was posting things with wrong format so I got other people editing my question in the middle. See my update, it seems there is an issue with the drop statements. – Dzyann May 23 '14 at 15:03
  • Interesting: you're idea that it is some sort of SQL injection filter being triggered may be right. I'm going to ask around – Jack Douglas May 23 '14 at 15:21
  • Jack, you and Aaron are right, it is in my end. I tried a bunch of things, and then he suggested to post in MSDN and it didn't work either. – Dzyann May 23 '14 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .